通达信指标公式有用吗

帮忙看看这个股票通达信指标公式能用吗?

AA:=REF(CLOSE,1);BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6,COLORYELLOW;
短线出击:IF(CROSS(短线买点,1) AND (短线买点<30),30,1),COLORGREEN;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长期线:=A+100,COLOR9900FF;短期线:=B+100,COLOR888888;
中期线:=D+100,COLORYELLOW,LINETHICK2;
见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线));
顶部区域:=中期线<REF(中期线,1) AND REF(中期线,1)>80 AND (REF(短期线,1)>95 OR REF(短期线,2)>95) AND 长期线>60 AND 短期线<83.5 AND 短期线<中期线 AND 短期线<长期线+4,COLORGREEN;
顶部:=FILTER(顶部区域,4);
底部区域:=(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ,COLORGREEN;STICKLINE( 底部区域,-4,0,22,0 ),COLORGREEN;低位金叉:50*(长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线 AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=长期线 OR REF( 短期线,1)<1 )),COLORRED;STICKLINE( 低位金叉,0,5,11,0 ),COLORRED;
FANG:IF(短线出击+低位金叉=80=0,100,20),COLORFF80FF,COLOR0000FF;

(通达信可用。已修改)

通达信的指标选股有用吗?

呵,指标只能用来参考

经传主力状态指标在通达信有用吗,谁有公式呢,要不要开通LVEL2数据?

在通达信可以用,不需要l2行情,不知道是不是你想要的,公式来自网络下载。

ZLCM:=EMA(WINNER(CLOSE)*7,3);{主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*8,3);{散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*10;{散户套牢筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<9 AND REF(ZSHTL,1)>9);{走牛天数}
ZSHJJ:=EMA(ZSHTL,89);
中线强势:IF(ZLCM/(ZLCM+SHCM)*20-4>0,2*(ZLCM/(ZLCM+SHCM)*20-4),0),COLORRED,LINETHICK2;{主力控盘筹码比率}
ZZLJJ:=EMA(中线强势,89);
ZJLRQD:=IF(INTPART(中线强势-ZZLJJ)>0,INTPART(中线强势-ZZLJJ)-1,0);{资金流入强度}
短线强势:IF(ZJLRQD>0 AND C>REF(C,1),ZJLRQD*1.5,0),LINETHICK3,COLORMAGENTA;
短线强势减昨日:短线强势-REF(短线强势,1),LINETHICK0;
SH8:=EMA(ZSHTL,8);
DKB:=IF(中线强势-REF(中线强势,1)>ZSHTL-REF(ZSHTL,1),1,0);
{主力控盘筹码}
STICKLINE(C>0,中线强势,0,3,0),COLORRED;
{筑底散兵坑}
STICKLINE(ZSHTL>=90,中线强势,0,3,0),COLOR66FFCC;
散户套牢系数:=INTPART(ZSHTL);
中线控盘:INTPART(中线强势)/5,COLORYELLOW,LINETHICK2;
短线超跌:IF(-ZJLRQD>0,ZJLRQD,0),LINETHICK2,COLORBLUE;
STICKLINE(短线超跌,ZJLRQD,0,3,0),COLORBLUE;
市场筹码总量:=INTPART(ZCMZL); 
STICKLINE(短线强势,ZJLRQD*1.5,0,3,0),COLORMAGENTA;
STICKLINE(中线控盘,中线控盘,0,3,0),COLORYELLOW;

编写通达信公式,设置参数和不设置,有区别吗?

如果不准备经常修改参数,就没必要进行参数设置,直接给出固定的值就好了。何必找那个麻烦

求大神帮忙写两个通达信指标公式。

首先分时图计算的均价线与系统显示的均价线有误差,但你这个思路可以编写,效果如图

通达信搓揉线的指标公式

{揉搓线}
前日上影线:=REF((H-IF(C>O,C,O))/(H-IF(C>O,O,C)),1)*100>60;
前日下影线:=REF((IF(C>O,O,C)-L)/(IF(C>O,C,O)-L),1)*100<30;
上影线:=(H-IF(C>O,C,O))/(H-IF(C>O,O,C))*100<30;
下影线:=(IF(C>O,O,C)-L)/(IF(C>O,C,O)-L)*100>60;
OK:=前日上影线 AND 前日下影线 AND 上影线 AND 下影线;
DRAWTEXT(OK,L,'揉搓线');
STICKLINE(OK,C,O,2.4,0),COLORYELLOW;
将上面的拷贝到主图指标最后一行就行,就能显示搓揉线第二根带长下影线的K线为黄色。
更多的编写教程可以参照
轻松学会用通达信软件编写公式和指标1
轻松学会用通达信软件编写公式和指标2
.......
https://kuaibao.qq.com/s/20190111A1I1S900
https://kuaibao.qq.com/s/20190112A0U91P00